[Loadstone] Compiling loadstone

Polaris-17 djpolar at gmail.com
Fri Jul 20 23:55:00 BST 2012


Ok, I understand you but I feel I "must" have the latest Loadstone 
version (improved GPS etc), and you don't want to share unsigned version 
so I have to build it myself. If doing step-by-step instructions from 
compile is all what i have to do then I compile it.
Thanks.,
Patrick.

P.s. Anyone on this list know how to compile Loadstone on windows, may 
it will be easier a bit?


On 2012-07-21 00:11, Shawn Kirkpatrick wrote:
> If you downloaded symbian_gnupoc-2012-07-17.tar.gz then that's for 
> 64-bit systems. This file was renamed to make it clearer but other 
> than that nothing changed so a crc wouldn't help much. You can always 
> compare the times and dates on files to see which is the latest.
> If you've never compiled anything before then trying to compile a 
> symbian program is not a good place to start. Symbian has the worst 
> compilation process I've ever worked with.
>
> On Fri, 20 Jul 2012, Polaris-17 wrote:
>
>> Hi,
>> Just one, very little suggestion. It will be great if you add CRC 
>> checksums to the compile instructions of downloaded symbian packages. 
>> Why? For example, Two days ago I've downloaded package and then after 
>> update I don't know it is for 32 or 64 bit systems.
>> Keep your great work! I've never compiled anything but I still trying 
>> to do that with loadstone and I hope it will be successful someday, 
>> somehow...
>> Best regards,
>> Patrick.
>>
>> On 2012-07-19 01:01, Shawn Kirkpatrick wrote:
>>> Hi Peter,
>>> glad to hear that things finally worked for you.
>>> The reason for creating symlinks for all the files is that when the 
>>> sdks compile programs they write files all over the place in the sdk 
>>> directories. This can cause a few problems: if you have multiple 
>>> users using the sdks then it's possible to get files overwriting 
>>> each other. You also end up with a poluted sdk environment after a 
>>> while since files from every project get left behind. Every user 
>>> that wants to use the sdks has to have write permission to the sdk 
>>> directories. If there's only one user of the sdks then this may not 
>>> be a problem but it still makes it hard to keep a clean environment. 
>>> I have no idea why symbian designed things this way, it makes no 
>>> sence at all.
>>> I hadn't thought of an inode quota, I've actually never hit this 
>>> problem. Do you have an old or small file system?
>>> Thanks for pointing out the problems with the documentation, I'll 
>>> have to fix that.
>>> The indirect expansion problem is interesting. I think make is using 
>>> /bin/sh as its shell so depending on what that points to on your 
>>> system you could get different behaviour than expected. A couple 
>>> reasons this didn't work for you could be: you have an old version 
>>> of sh installed, or you have a symlink for /bin/sh that points to a 
>>> not quite compatible shell. Debian and ubuntu systems seem to point 
>>> this to /bin/dash by default. In my experience this causes no end of 
>>> trouble, certain shell scripts just won't work. Changing the symlink 
>>> to point to /bin/bash just makes things work.
>>> What distro and version are you running? Maybe I'll have to include 
>>> more notes in the documentation about other distros.
>>>
>>> On Wed, 18 Jul 2012, Peter Lecky wrote:
>>>
>>>> -----BEGIN PGP SIGNED MESSAGE-----
>>>> Hash: SHA1
>>>>
>>>> Hi Shawn,
>>>> I downloaded the package and ewerything works. I had one problem with
>>>> creation of simlinks in user's home dir, because of inodes quota.
>>>> Finally i created only one simlink ln -s /usr/local/gnupoc gnupoc and
>>>> it worked. Is there any reason why it is necessary to create a simlink
>>>> for each file and directory?
>>>> There is one small inconsistency in compiling instructions:
>>>> "running make without specifying any target will compile the program
>>>> for all supported versions. This will create a .sis file for each
>>>> version and a .sis file for third and fifth editions signed with your
>>>> devcert."
>>>> You have to run make sis after make without target to create sis
>>>> files, make without targets only compiles the code.
>>>>
>>>> Some people should have problems with ! in {} in the Makefile. I
>>>> actually don't know why, but my bash don't likes indirect expansion.
>>>> :) I had to remove exclamations to be able to compile.
>>>> With best
>>>> Peter
>>>> D?a 18. 7. 2012 6:26 Shawn Kirkpatrick  wrote / napísal(a):
>>>>> I've updated the instructions for compiling loadstone in the latest
>>>>> code from subversion. I've also updated the needed symbian sdks.
>>>>> The file is now called symbian_gnupoc-2012-07-17.tar.gz and
>>>>> contains all the sdks needed for compiling. This file is around 1.8
>>>>> gigs so please don't download it unless you really plan to compile
>>>>> loadstone code.
>>>>>
>>>>> _______________________________________________ Loadstone mailing
>>>>> list Loadstone at loadstone-gps.com
>>>>> http://www.loadstone-gps.com/mailman/listinfo/loadstone
>>>>>
>>>> -----BEGIN PGP SIGNATURE-----
>>>> Version: GnuPG v1.4.10 (MingW32)
>>>> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
>>>>
>>>> iQEcBAEBAgAGBQJQBqvKAAoJEKitnP1f3fESy0UH/jfC4LjkyN7twX3eMx5frunz
>>>> VRbcH3wu/7ALkyZPgLqX+va+yb996snQZTxLH7FzuDRKcg2ZpX4+mgUmNIyVnbtk
>>>> 2+lvnLchtbjDUkgyrxikVGk0SmLjzeobPbwwK1atPuY47n4/dcAk83/r4YuHAKpz
>>>> eqBVm3b6004aOySqIiBp10prDQzGi1EDeMiu2Xf90NC512okqZxkgcb0y8O/yJuY
>>>> 1L2GOdc4pPUHx9bieof534vhLYExLPgYE9GoiLHM95LAvQl4mXgfitqhFNpKA62F
>>>> SinpWQx97MOuUyLQck8g2YAV2IlpEbr83PiHoEinydMq8nRVCeu2PDNKRN44Qes=
>>>> =ryeA
>>>> -----END PGP SIGNATURE-----
>>>> _______________________________________________
>>>> Loadstone mailing list
>>>> Loadstone at loadstone-gps.com
>>>> http://www.loadstone-gps.com/mailman/listinfo/loadstone
>>>>
>>>>
>>>
>>> _______________________________________________
>>> Loadstone mailing list
>>> Loadstone at loadstone-gps.com
>>> http://www.loadstone-gps.com/mailman/listinfo/loadstone
>>
>>
>
> _______________________________________________
> Loadstone mailing list
> Loadstone at loadstone-gps.com
> http://www.loadstone-gps.com/mailman/listinfo/loadstone

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.loadstone-gps.com/pipermail/loadstone/attachments/20120721/e9044400/attachment-0001.html>


More information about the Loadstone mailing list